Class org.apache.poi.hssf.usermodel.HSSFWorkbook does not implement the requested interface org.apache.poi.ss.usermodel.Workbook

用POI导出excle的时候报错,报错如下:

java.lang.IncompatibleClassChangeError: Class org.apache.poi.hssf.usermodel.HSSFWorkbook does not implement the requested interface org.apache.poi.ss.usermodel.Workbook

网上查了下,报java.lang.IncompatibleClassChangeError错的原因poi的jar包重复了,查了下jar包,果然有重复的包,删掉某个jar包,问题就解决了。

poi jar包重复

如若转载,请注明出处:http://www.codingwhy.com/view/854.html

联系我们

在线咨询: 点击这里给我发消息

邮件:731000228@qq.com