python安装包出错:error: Microsoft Visual C++ 14.0 is required

今天在安装python的扩展包的时候提示出错:Microsoft Visual C++ 14.0 is required

我是通过以下方法解决的,比如我是安装pymssql的时候报错的。

1、首先访问 https://www.lfd.uci.edu/~gohlke/pythonlibs/ 网站,找到pymssql

QQ截图20180112162151.jpg

因为我是python36的32位版本,所以我下的是 pymssql‑2.1.3‑cp36‑cp36m‑win32.whl,并把他放到了D盘。

2、在cmd里面执行以下命令

pip install D:\Twisted-17.5.0-cp36-cp36m-win_amd64.whl

通过以下步骤,安装就成功了!

如若转载,请注明出处:http://www.codingwhy.com/view/895.html

联系我们

在线咨询: 点击这里给我发消息

邮件:731000228@qq.com